Checking Your System
Flash plugin
Supported
Not Supported - to get flash plugin visit this link
Browser
NOTE: For optimal course performance, download Google Chrome or Mozilla Firefox.
Internet Explorer 11 does not provide the audio/video plug-ins required. Downgrade
to Internet Explorer 10.
Browser version
Operating system